Scrobbl not scrobbling when I play tracks though an Alpine car adapter

  • Scrobbl not scrobbling when I play tracks though an Alpine car adapter

    The old version used to, I swear it.

    I'm using the fix that was posted here for the toggling of the menu icons, and it SEEMS as if that version broke it.

    I'm using an iPhone 3GS - AT&T - iPhone OS 3.1.0

    If you need logs or anything I can provide, just give me a bit of time to grab them.

    • [Raderad användare] sa...
    • Användare
    • 19 okt 2009, 04:25
    I'm not sure what the kind of car adapter I'm using, but the same thing happened to me.

    It used to work on my car adapter, but it recently stopped working..

  • Can you try the reinstalling the one that's on cydia and see if that one works?
    Is your radio on or are you in flight mode?

    I haven't been able to replicate with my touch in a car dock so it's probably a connectivity/radio issue somehow. Logs might help tracking down whats going on.

  • I'll try uninstalling and installing the one in Cydia, and try it on my lenghty drive home today. I'll let you know how it goes.

  • tried this today, played about 12 tracks or so, none of them made it.

    • Arg0t sa...
    • Användare
    • 24 okt 2009, 16:43
    Same issue. iPhone with 3.1.2 and Scrobbl 9.5.1. Scrobbles perfectly when undocked on either WiFi or 3g. Pop it in the dock and nothing is queued never mind uploaded.

    2009-10-24 08:50:34 +0100 Loaded queue with 0 items from /var/mobile/Library/scrobbled/queue.plist
    2009-10-24 08:50:35 +0100 Status bar is not enabled
    2009-10-24 08:50:35 +0100 Starting scrobbled
    2009-10-24 08:50:36 +0100 Found player at pid: 1273
    2009-10-24 10:32:33 +0100 Network connection changed, handshaking
    2009-10-24 10:32:33 +0100 Handshake scheduled in 5.0 seconds

    Went for a drive this morning, iPod in the dock for 90 mins, not 1 track scrobbled.

    I've uninstalled via Cydia, logged in via ssh and deleted the plist files and any other scrobble folders I could find. Reinstalled latest version via dpkg with same results.

    Hope this helps track the bug down. FYI worked perfectly up to the 3.1.2 upgrade.

    • n808 sa...
    • Användare
    • 26 okt 2009, 16:41

    same problem Pioneer DEH-P510UB (USB)

    I, too, saw scrobble as the main reason for jailbreaking, but it died with the 3.0 upgrade. I was very happy to find scrobbl, and it works great while playing normally in a wi-fi area. However, it fails to scrobble or queue any tracks while playing connected to my Pioneer DEH-P510UB car stereo via USB -> iPhone connector. Any information I can provide, I would be happy to.

    EDIT: iPhone 2G, f/w 3.1, scrobbl 0.9 (cydia)

  • It worked for me on 3.0... it seems to have been an issue just recently, either with the 3.1 update, or with the update to srobbl to fix the status bar toggle.

    • n808 sa...
    • Användare
    • 26 okt 2009, 21:55
    Yes, I meant the old 'scrobble' died with 3.0, if not even earlier... I never tried 'scrobbl' until after I upgraded to 3.1.

  • any logs needed let me know where to get them from.

    • mojimbo sa...
    • Användare
    • 6 nov 2009, 06:03
    Same thing happened to me. Scrobbling through my car radio via USB cable used to work fine on 3.0 but doesn't register anymore after upgrading to 3.1. It still scrobbles fine aside from that one scenario, though. I tried to uninstall and reinstall through Cydia multiple times with the same result.

    • Arg0t sa...
    • Användare
    • 12 nov 2009, 14:37
    Any idea if it is possible to fix? 50% of my scrobbles come from my phone in the car dock so missing this.

  • yeah same here, probably 90% of my scrobbles come from there :(

    it doesn't seem to be scrobbling when ANYTHING is plugged in, i havn't even been getting scrobbles when its plugged into the power and playing music sometimes.

  • got the same problem here... any word on if a fix is even being looked into for this? or should I be looking for another app to switch to? has anyone found an older version of the app and reinstalled it to see if it was working fine?

  • Sorry I've been busy and neglecting this issue.

    Could you try 'iscrobble lite' from the app store and see if that picks up plays while it's running?

    If iscobble lite works it should be easily fixable, I'll just need some help tracking down the bug. However from looking at the logs it appears that scrobbl is still running OK and querying what track is playing. But doesn't get the correct answer. So I suspect this may either be an apple issue, or that your docks aren't playing in the same way as a normal ipod play.

    This issue isn't helped by the fact that my car adapter works so its difficult for me track down!

    • Arg0t sa...
    • Användare
    • 18 nov 2009, 12:22
    Can confirm that iscrobble does not scrobble when docked. Iscrobble fails to see a track playing whilst in the dock, pretty much the same as we see in the scrobbl logs.

  • Although I just installed Scrobbl last night, I can also confirm that when my phone is plugged in (in my Alpine deck, or computer) the program fails to recognize songs to scrobble. Unplug, and it's good to go, but that's not what I need it for.

  • anything happening w/ fixing this issue?

  • I'm getting the same issue with scrobbl. In my case, it seems that once I plug the iPhone into my car, no more tracks are scrobbled, even after unplugging the iPhone from the car. To get scobbling working again, I have to go into SBSettings and un-toggle and re-toggle the "SBSettings Scrobble Toggle" icon.

    • n808 sa...
    • Användare
    • 12 dec 2009, 01:55

    iScrobble Lite and USB car stereo iPhone connection

    hippopotenuse: I tried iScrobble Lite today. It worked as expected when playing songs normally. When my iPhone is connected to and controlled by my car stereo, it does _not_ detect any playing songs, and can not control playback.

    When my iPhone is controlled by my car stereo, the Play arrow shows as normal in the iPhone UI, the currently playing song shows on the Lock screen, but when starting the iPod application, it shows only "Accessory connected", to indicate the car stereo has full control of playback.

    I think my car stereo has a mode where it just plays whatever the iPhone is playing, also over USB, but will then not show any song info, and all playback control must happen on the iPhone. In this mode, I bet scrobbl would work just fine, but it defeats the main purpose of the USB adapter connection, IMHO.

  • that is EXACTLY what i'm experiencing as well.

    however it USED to work no problem at all at least on iPhone OS 3.0.0

    • skraatz sa...
    • Användare
    • 29 dec 2009, 20:10
    Same problem here using the iPhone 3G on my Audi Music Interface (connected to the stock navigation system). Any update on the issue yet?

    • darkfalz sa...
    • Användare
    • 30 dec 2009, 02:36
    Any status on this? Most of my music listening is done in my car, so 90% of my crappy music isn't scrobbled and that's no fun. :-)

    • Arg0t sa...
    • Användare
    • 30 dec 2009, 23:28
    Think it's an apple issue rather than a scrobbl problem, 3.1 seems to have changed the functionality whilst the iPhone is connected to a dock. Basically preventing scrobbl or any other app seeing the details of the song being played.

  • well this really sucks then... :(

Anonyma användare kan inte skriva inlägg. Vänligen logga in eller skapa ett konto för att göra inlägg i forumen.