iOS 5.0

 
  • iOS 5.0

    Scrobbl 0.9.5 doesn't work with iOS 5.0

    • hatkirby disse...
    • Usuário
    • Set 30 2011, 15h51
    Second. iOS 5 is almost unbearable without Scrobbl.

    • [Usuário excluído] disse...
    • Usuário
    • Set 30 2011, 20h00
    I agree with kirby, I don't think I could stick with iOS 5 without the ability to scrobble tracks.

  • ...

    This sucks! I was so happy because I thought it would scrobbl. :(

  • Oh, please get this working again. Its still the only reason for me to JB and would SO love to get native support for last fm in the iOS music player. But until that, this app is by far the best solution out there.
    So, please get this app going on iOS 5.

    För kärlek som aldrig kan dö, men inte heller leva.
  • I think I know the issue, and it should be quick to fix. I might be too busy to fix it before the Wednesday release, but I use scrobbl everyday so it will be fixed soon after.

    If you're interested I think the issue is just that apple has changed the name of the music player process and so scrobbl doesn't think it's running.

    • [Usuário excluído] disse...
    • Usuário
    • Out 11 2011, 18h15
    hippopotenuse said:
    I think I know the issue, and it should be quick to fix. I might be too busy to fix it before the Wednesday release, but I use scrobbl everyday so it will be fixed soon after.

    If you're interested I think the issue is just that apple has changed the name of the music player process and so scrobbl doesn't think it's running.

    could you name the file to fix (and its location)?

    • mythjm disse...
    • Usuário
    • Out 13 2011, 13h37
    Can't wait for this to be working again.

    • sickyd disse...
    • Usuário
    • Out 13 2011, 19h28
    it probably is the music process name, since they split videos and music into two separate apps, they would need to rename it from some generic "ipod" name to "music" and "video". they also need to update mobilesubstrate for iOS5 too, so that might be a caus as well.

    • GolemDX disse...
    • Usuário
    • Out 14 2011, 11h06
    MobileSubstrate is updated, it is most likely the process name. I don't exactly understand why it was a good idea to split the processes if they didn't even upgrade Videos at all, but if anybody can get it compiling with the fix, that would be great.

  • OK so I think I've managed to rebuild for iOS 5. The deb is here.

    I haven't tested it at all beyond checking some songs scrobble and that it works OK with the sbsettings toggle so no promises.

    Also if anyone has any iOS 4 devices could you check this deb works OK on there so I can upload to cydia.

    Thanks

  • I can confirm that 0.9.6 is working on my iOS 5 device. Any chance of getting the source code?

  • Sure. You should be able to check it out from svn here

  • Great job hippoptenuse! I'm waiting for it to be uploaded to Cydia, and then i'm jailbreaking just for this. Will there EVER be a native support for last fm scorbbling?

    För kärlek som aldrig kan dö, men inte heller leva.
    • aracno disse...
    • Usuário
    • Out 16 2011, 17h00
    Thanks hippopotenuse, 0.9.6 working fine iOS 5.0 with the sbsettings toggle.

    I've tried on a 3G with 4.2.1, when running dpkg -i scrobbl, I got:

    Setting up org.chris-w.scrobble (0.9.6) ...
    /var/lib/dpkg/info/org.chris-w.scrobble.postinst: line 3: /Applications/scrobble.app/launchctl: Bad CPU type in executable

    It installed, but it won't launch.

    • mr-benx disse...
    • Usuário
    • Out 17 2011, 12h28
    Thanx hippopotenuse, happy scrobbling on ios5!!!

  • how should I apply the source code? Should I download the svn? Is the updated app now on Cydia?

  • i love you hippo :P

  • OK here's another attempt. Hopefully this should work on pre iOS 5 and older devices. Let me know if it does so I can update cydia.

    @BrokenxStars: you install the deb file by running 'dpkg -i scrobbl_0.9.6.deb' on your phone.

  • Works perfectly (iOS 5), thanks hippo :3

    Sigs are for losers
    • aracno disse...
    • Usuário
    • Out 17 2011, 21h09
    It worked at 4.2.1 on the old 3G. Thanks man!

  • Great, thanks aracno. It should be updated by bigboss in cydia in the next day then.

    • aracno disse...
    • Usuário
    • Out 17 2011, 21h24
    This 3G is from a friend that asked me to revive it, if you want, I can test with 3.1.2 too.

  • I think it should be OK on 3. I've set it to run on anything above 3.0.

    The issue before was just that I'd accidentally only built for the processor that's in the 3GS and above rather than a iOS 5 vs 4 issue.

    • aracno disse...
    • Usuário
    • Out 17 2011, 21h49
    Right, that armv6, armv7... Ok then.

Usuários anônimos não podem postar mensagens. É preciso fazer login ou criar uma conta para postar nos fóruns.