QTScrobbler refuses to admit that the iTunesDB exists

 
  • QTScrobbler refuses to admit that the iTunesDB exists

    I just started using QTScrobbler to scrobble via MediaMonkey. But when I try to locate the iTunesDB on my iPod Classic, I get the error "Error parsing file: Parsing failed -- unable to find iTunesDB in G:\iPod_Control\iTunes." But when I browse there via Explorer, the file is clearly there. Any suggestions?

    I am using an iPod Classic 120GB.
    I am using Windows 7.
    I am using QT 4.5.2.
    Both MediaMonkey and iTunes are closed.

    Help!

    • Beowulf disse...
    • Usuário
    • Out 11 2010, 2h58
    When you're opening the iTunesDB in QTScrob, are you browsing to the root of your device, or are you going directly to the iPod_Control/iTunes folder? You should be going to just the drive letter. QTScrob automatically looks into those folders.

  • I'm browsing via the letter. Here's a screengrab.

    • Beowulf disse...
    • Usuário
    • Out 11 2010, 15h39
    Select G: - don't enter into iPod_Control.

  • YAY!

    Thanks so much. That seems so obvious, but I guess it wasn't.

    • RedFIag disse...
    • Usuário
    • Dez 23 2010, 2h59

    hmmmmmmmmmmmmmmmmmmmmmmmmmmmmmm

    When I browse to the letter of my ipod's drive, I get an error. And yeah I can see iTunesDB in Explorer.
    I've tried with both 0.10 (Error parsing file: Parsing failed - unable to find Play Counts in J:) and 0.11 (Error parsing file: Parsing failed -- unable to find iTunesDB in J:\/iPod_Control\iTunes/Play Counts)

    Windows 7 64-Bit home premium
    5th gen ipod classic 30gb
    itunes v10.1.1 (not that that probably matters but i tried QT because itunes 10.1.1 and last.fm have failed to scrobble)
    also, none of the music on my ipod is also on my computer.

    ...halp plis? DDDDD:

  • i've the same problem. i've 64bit windows 7 and i installed QTscrobbler v0.10 and an iPodTouch and i can scrobbler my ipod musics to lastfm profile. i tried to click on " open itunesDB" and appear all my drivers but none of them are my ipod ( tried to click in every driver i have and nothing)

    someone can help me find whats going on?

    • D4GZ disse...
    • Usuário
    • Jan 5 2011, 21h17

    ARGH!

    Same here, W7. Very frustrating.

    • Zarggg disse...
    • Usuário
    • Jan 6 2011, 2h37
    The program appears to be looking for a file named "{drive}\iPod_Control\iTunes\Play Count", which does not exist. IIRC, the iPod stores playcount information in the iTunesDB database file.

    If you notice that a track I've scrobbled has wrong data, please send me a message with the correct info.
  • Zargg but you can scrobble from ipod?

  • I have 64bit windows 7, iPod nano 6g, QTscrobbler v0.10 GUI.
    My iPod is on D:\, iTunes DB should be there in folder iPod_Control. But
    QTscrobbler doesn't see it. It sees only this:

    When I'm clicking on D:/, there's "Error parsing file: Parsing failed - not iTunes DB file D:\"
    Please, help! I'm trying to do something with this for 3 hours.

    • Zarggg disse...
    • Usuário
    • Jan 10 2011, 20h35
    @doutorsaco:
    No. The program refuses to read the data from the iPod, because it is looking for a file that does not exist. (If this is not the case, then the UI message should be changed to reflect what is actually happening.)

    If you notice that a track I've scrobbled has wrong data, please send me a message with the correct info.
  • i install a program called touchcopy and this prgm actually find the ipodControl drive and the famous file iTunesDB and the connection with last.fm but its was a trial version and maybe thats the reason the last.fm connection is not available.

    • Beowulf disse...
    • Usuário
    • Jan 14 2011, 3h05
    I'd guess that touchcopy uses the iTunes API to talk to the devices (since iTunes is listed as a requirement). I don't have an recent ipod with this issue to code against, but if anyone was to come up with a suitable patch I'd gladly add it.

  • Yah, i have the same problem, the weird thing is that i can find iTunesDB in explorer but QTscrobbler doesn't. I'm running windows XP and i have a 16 GB Generation 4 iPod Nano

    • paco9999 disse...
    • Usuário
    • Fev 23 2012, 11h38

    same problem, any solution?

    Hallo, I have been reading the posts. This is from June. I have the same problem, did you find any solution?
    Cheers

    • parkku disse...
    • Usuário
    • Set 5 2012, 21h02

    Have you tried version 0.11?

    I tried QTScobbler version 0.11 after not succeeding with 0.10 and managed to scrobble again. I had the same parsing failure with the older version. My OS is Win7 and my iPod is 4th generation Nano.

    Yoiu can dload 0.11 here:
    http://www.last.fm/group/QTScrobbler/forum/43047/_/598317

    Hope that helps!

  • Itunes "steals" the ItunesDB

    I had this problem too. My QTScrobbler do not found the ItunesDB. The Itunes was setting to open automatically when the ipod is connected to usb. So the Itunes "steals" the ItunesDB from the ipod and therefore the QTScrobbler reports this error too. So, do not permit that Itunes acess the ipod before the QTScrobbler.

Usuários anônimos não podem postar mensagens. É preciso fazer login ou criar uma conta para postar nos fóruns.