0.11 preview version

 
    • Beowulf disse...
    • Usuário
    • Mai 22 2010, 3h41
    0.11 uses the newer WPD API, whilst 0.10 used WMDM - but both should see the same drives. Could you pastebin the output at the highest debugging level with 0.11?

  • Sorry for taking so long. Kinda forgot with exams.

    Uh for some reason I can't copy all the info from the highest debug level (trace)
    Instead it just copies info from level 2.
    http://pastebin.com/Z8RM7Gx4

    Screenshot of the console.
    I'm assuming the issue is with the fact that it possibly reads the memory stick as merely a folder instead of a seperate device.
    http://dl.dropbox.com/u/6252145/more.png

    • Beowulf disse...
    • Usuário
    • Mai 28 2010, 22h26
    If you were using the memory stick to store camera photos (or photos from the phone), then it looks like 0.11 is reading the stick without problems.
    If so, then I wouldn't worry about it.

  • Any chance for a release of 0.11? Just asking because building 0.10 on Linux is broken due to the missing definitions of uint32_t in libscrobble.cpp. Not that much of a problem but unpleasant for package maintainers to patch.

    • Beowulf disse...
    • Usuário
    • Jun 14 2010, 12h30
    Soon hopefully. I want to see what I can do on the Nano 5g front before releasing, and do a few other checks (like lang translations). Are you the gentoo maintainer?

  • No, but I made a "package" (in Gentoo, it's called an ebuild file) and a patch for my own purposes and posted it in the applicable bug report on bugs.gentoo.org. Another thing is that your Makefile for the cli version ignores any setting a user might have for his own CFLAGS. In the Gentoo ebuild there's also a a sed oneliner fix for this (not from me, I modified it though).

    • Beowulf disse...
    • Usuário
    • Jun 14 2010, 20h12
    If you're talking about the 0.10 Makefile, that has been removed in 0.11, since the entire program has moved to QT4 internally, and builds are now qmake based.

    • Beowulf disse...
    • Usuário
    • Jun 15 2010, 0h34
    I've updated the builds at the start of the thread to include support for compressed iTunes Databases - so it should now read Nano 5gs, as well as iphone 3's and up (as well as a bug fix for multiple played tracks with the itunes database). Please test and let me know.

  • I used this, some tracks I know I've listened to. Well more specifically.. Tracks from specific artists.. For example, Ensiferum. I listen to them all the time, but it's not actually imported any Ensiferum. I can list more artists it's missed but I'm sure it's not needed. xD Does anyone know why/is there a reason for this? It doesn't miss out specific tracks, it misses out entire artists. xD (Sorry if it makes no sense to whoever is reading this. T_T) Though it's imported around 1,500 tracks with no problem ignoring the artists it's missed. xD

  • Hello!

    I'm just curious, but will devices in MSC mode be supported? I have an Archos 5 IT (Internet Tablet) with Android, and I have it set up in MSC mode. I can switch to MTP mode, but the player I'm using to sync with is currently having issues with it in MTP mode.

    OS: Windows 7 x64.
    Device: Archos 5 IT w/Android

  • Don't know if anybody's gonna read this - but according to my expierence the only way to make your Cowon D2 scrobble your songs you put on it in MSC mode is re-copying them in MTP mode.

    This works with internal memory and takes quite some time - but not too much.
    Dunno about external memory - I don't use any.

    I tried various work-arounds like making the D2 rescan the whole memory by changing the system language or renaming/moving the folders in MTP mode.

    But apparently the only solution is to copy everything from your PC to the player again :(


    Apart from that it works great!

    OS: Windows 7 x64
    Device: Cowon D2 v2.59
    QTscrob: 0.11-x64-preview

    • lestatar disse...
    • Usuário
    • Set 30 2010, 21h03

    0.11 QTSrobbler - MTP Sony E345 causes error

    Hey hope this helps...

    OS: Win XP SP2, using 32bit qtscrob.exe.
    Device: MTP Sony E345

    - With device plugged in, Open MTP Device yields the following error:
    ERROR: Failed to CoCreate
    Parse_MTP::~Parse_MTP

    FYI, qtScrobbler 0.10 works perfectly with the same device, same conditions.

    hth and thanks for the hard work! Am new to scrobbling, but man, great stuff this qtscrobbler applet. :D

    cheers,
    -lestatar

    • Beowulf disse...
    • Usuário
    • Out 1 2010, 4h59
    Which version of MS Media Player do you have installed?

    • lestatar disse...
    • Usuário
    • Out 1 2010, 16h42
    Hey Beowulf:
    Please don't laugh - WMP9. I have not updated WMP on purpose as I detest the application.

    However, FYI, I do have the MS MTP Porting Kit installed on the machine where qtscrobbler 0.11 returned the error.

    I hope you please do not advise me to install a newer version of WMP, if this will possibly make qtscrobbler 0.11 work - I really wish to avoid this. If that is the only solution, then I will simply continue to use v0.10 which seems to function perfectly.

    Thanks a ton,
    -lestatar

    • Beowulf disse...
    • Usuário
    • Out 2 2010, 16h16
    v0.10 uses the now depreciated WMDM API. For 0.11 I changed to WPD, which on XP requires WMP 11. The change was required to make QTScrob compile on Windows 7, and also to allow 64-bit binaries.

    • lestatar disse...
    • Usuário
    • Out 3 2010, 6h22
    Beowulf thanks so much for responding. 75% of what you wrote is over my head, but I do indeed get the message. I will consider updating to WMP11 in order to use 0.11, though I will review the change log to try and determine if I need the new stuff you added. I am, regrettably, old school with a degree from in "if it ain't broke, don't fix it". I do very much appreciate the info. Thanks once again and also for all your work on qtscrobbler. cheers, -lestatar

    • TJOHO disse...
    • Usuário
    • Out 16 2010, 9h16

    iPhone support?

    You mentioned iphone support above.

    I use 0.10 for scrobbling an ipod classic, but as the iphone does not get assigned a drive letter in win7, qtscrobbler can't access plays on it.

    Will this problem be remedied in 0.11?

    • Beowulf disse...
    • Usuário
    • Out 19 2010, 0h55
    Nope. If someone wants to go ahead using the iTunes program libraries, then feel free, but since I don't own a iphone or itouch it'd be pretty hard for me to do so.
    If your iphone or itouch is jailbroken, then there are ways (sshfs etc) to assign it a drive letter or mount point.

    • Bazirker disse...
    • Usuário
    • Nov 2 2010, 2h15

    Ubuntu linux?

    Hi! This software is great on my windoze box (been using it to scrobble from my rockbox'd Cowon D2), but any progress on the linux front? I run Ubuntu 10.04 linux.

    • Beowulf disse...
    • Usuário
    • Nov 5 2010, 1h18
    At the moment you can build from source ("apt-get install libqt4-dev pkg-config libmtp-dev", then download from SVN) or wait until I finally have enough time to check everything is the way it should be before releasing (at least 6 weeks away).

  • Does QTScrobbler scrobble FLAC files?

    • Bazirker disse...
    • Usuário
    • Nov 15 2010, 5h40
    Yes, my flac files on my Cowon D2+ are scrobbled just fine (via a scrobbler log kept by Rockbox.)

  • Sorry, but i ask about MTP mode, without Rockbox)

    • Bazirker disse...
    • Usuário
    • Nov 17 2010, 3h01
    It probably depends on what player you're using. Why wouldn't it scrobble FLAC files, assuming your player is capable of playing them? Give it a shot and let us know! :)

    • DruiD_ff disse...
    • Usuário
    • Nov 20 2010, 23h58
    Beowulf, is it bad to pass track length getted via last.fm database instead real track length?

    Doom.. or be doomed
Usuários anônimos não podem postar mensagens. É preciso fazer login ou criar uma conta para postar nos fóruns.