No Scrobbling (neither nor Rhythmbox Plugin)

  • No Scrobbling (neither nor Rhythmbox Plugin)

    Hi... The topic is very self descripting.

    So first about the Rhythmbox plugin:
    The Plugin for Rhythmbox doesn't even care about what I play, it shows 0 tracks scrobbled and 0 submitted, although the Status is OK. The streams in the plugin just skip around all the time without doing any sound.

    So I installed the (and just the client, no plugins):

    I can listen to music via the client, and it is also scrobbled and sounds good as always. But the clien't won't recognise any music played in Rhythmbox. Do I need some plugin like in Windows for this to work? If yes, where can I get it?

    Please forgive me that I am not a Tux with a beard... And please help me, the guys in the Client Support Forum just ignored me -.-

    Hope you can help me :)
    lazlow aka. Edguy0815

  • Eh, I have Fedora 8, And Rhythmbox 0.11.3 I guess.. *forgot to mention*

  • Hi

    I have same problems with rhythmbox, but I am tryin to use since today and there are no tracks scrobbed. My Status says that scrobbing failed too often.
    I am using Ubuntu 7.10 with Rhythmbox 0.11.2.
    Can anyone help?

  • Same problem on Debian Lenny.

    Software is like sex! It's better when it's free! ;-) -Linus Torvalds-
  • At least I'm not the only one... I wish it would throw some sort of error... but the Tracks I play don't even appear somewhere in the log...

  • Hi folks,

    I have good news for you: try to use Rhythmbox 0.9.6 - it works perfectly!

    I am using Ubuntu 6.10 Edgy and I don't have installed any other

    Just add your username and password:
    Menu - Plugins - - Configurate

    Now listen carefully... ;-)

  • Finally found 0.9.6 on the net, but it makes an shitload of errors when I try to ./configure... no matter if I have Rhythmbox 0.11.X installed

  • Eh, how funny... reinstalled 0.11.3... now it works, but now my profile says that I try to submit songs I heard before the last submit and the plugins says that the scrobbling failed to often :(

    Oh man, I just wanna scrobble...

    • [brain] said...
    • User
    • 28 Feb 2008, 18:25
    Same for me here...
    Running Rhythmbox 0.10.1 on Debian testing.

    But I think this is a known issue:

    • olyons said...
    • User
    • 28 Feb 2008, 20:53
    It works for me if I run:

    tail -f /home/[username]/.gnome2/rhythmbox/audioscrobbler.queue when I have Rhythmbox running

    I don't really know why it works but I'm scrobbling now so I'm happy! (I'm running Fedora 8 and Rhythmbox 0.11.3)...

  • How do you do precisly?

    First launch Rhythmbox, start to play a song and after "tail -f /home/[username]/.gnome2/rhythmbox/audioscrobbler.queue"

    Or first "tail -f /home/[username]/.gnome2/rhythmbox/audioscrobbler.queue" and after launch Rhythmbox ans songs?

    Patrick "FirBolg" Andries
    Un club de jeux de rôles, un vrai?? Les Saigneurs du Chaos
    Une boutique de produits tibétains? Dupkang
    Une véritable alternative à Windows(C/TM/...)? Ubuntu
    "No wise man would ever harm the environnement" - Buddha, 2500 years ago
    "Nous sommes englués dans l'embouteillage de nos propres pensées" - Chögyam Trungpa
    • olyons said...
    • User
    • 7 Mar 2008, 15:28
    oh, sorry for not being specific about the order in the first post. I start "tail -f /home/[username]/.gnome2/rhythmbox/audioscrobbler.queue" before I start Rhythmbox and then leave it running until I've closed Rhythmbox.

    • myfunny said...
    • User
    • 7 Mar 2008, 23:38

    wow, it works.

    a hint: to avoid using the command line each time you want to listen to music, you can add a launcher ("custom application launcher") to your panel with this text under "command":

    tail -f /home/[username]/.gnome2/rhythmbox/audioscrobbler.queue && rythmbox


    • Sn3ipen said...
    • User
    • 15 Apr 2008, 20:09


    Thanks alot. I have now set this code as automatic startup:)

    If I ask you to dance, you better say never.
    Cause a dance with me might last you forever.
  • works for me too although i really don't know why :(
    Using Mandriva 2008 and rhythmbox 0.11.2
    i have added rhythmbox to GNOME session autostart long before so i just modified the entry in GNOME session manager et voilá :)

    PS: I found out some more things about it:
    The error only occurs if the initial queue file is empty. This usually happens, if you exit the programm normally, that has scrobbled some tracks before. "echo "x" > ~/.gnome2/rhythmbox/audioscrobbler.queue && rhythmbox" will do it as well with the advantage of not having the slight performance hit due to tail constantly running in the background. It may though work better for some distributions and conditions as well.

    • Ser3f said...
    • User
    • 19 Apr 2008, 20:43



    Edited by hjbardenhagen on 21 Jul 2011, 07:11
  • Working for me now

    I was having this problem a few months ago and found this thread. The "tail" trick wouldn't work for me. Tonight I started Rhythmbox and noticed it looked different. I clicked on Plugins and the plugin showed 1 track submitted.

    I am running Debian Lenny and Rhythmbox is version 0.11.5.

    • bgoodr said...
    • User
    • 27 Apr 2008, 20:13

    Fixed by building from scratch (instructions included)

    I had to build Rhythmbox from source (from the 0.11.5 tarball) on my Debian Lenny machine in order to get scrobbling to work. Here are some tips for what I had to do:

    I had to uninstall the old rhythmbox:

    apt-get remove rhythmbox

    The configure and build line I used was:

    ./configure \
    --prefix=$HOME/rhythmbox/install \
    --enable-python \
    --with-ipod \
    --with-cd-burning \
    --disable-scrollkeeper \
    && make && make install

    Note that this is for my installation into a subdirectory underneath my HOME directory, which mandated my using the --disable-scrollkeeper option to avoid the build failure that results from scroll-keeper-update's attempt to update some files under /var/lib.

    There were tons of Debian packages I had to install. From the Rhythmbox chatroom, I found that I could get all of them with one install command:

    apt-get build-dep rhythmbox

    But I ended up only using that command to get hints as to which packages are needed. Otherwise, it said it would install 845MB worth of packages. I believe not all of them are needed (I think the build-dep package just grabs all of the packages used on the build machine they use to build rhythmbox, which probably includes a lot more than Joe User needs).

    The failures during the ./configure run do not show the Debian package name, but complain about some files with .pc extensions. I managed to find those files via a apt-file search command:

    apt-file search gstreamer-0.10 | grep '\.pc$'

    This returned:

    libgstreamer0.10-dev: usr/lib/pkgconfig/gstreamer-0.10.pc

    So the package to install was libgstreamer0.10-dev

    After that, if you run rhythmbox with the -D option to see diagnostics from the plugin, you'll see the scrobbling succeed. Look for lines in that output like this:

    (12:47:40) [0x6a2740] [rb_audioscrobbler_submit_queue] rb-audioscrobbler.c:1060: Submitting queue to Audioscrobbler
    (12:47:40) [0x6a2740] [rb_audioscrobbler_print_queue] rb-audioscrobbler.c:1649: Audioscrobbler submission (1 entries):
    (12:47:40) [0x6a2740] [rb_audioscrobbler_print_queue] rb-audioscrobbler.c:1661: 1 artist: Abba
    (12:47:40) [0x6a2740] [rb_audioscrobbler_print_queue] rb-audioscrobbler.c:1662: album: Gold-Greatest Hits
    (12:47:40) [0x6a2740] [rb_audioscrobbler_print_queue] rb-audioscrobbler.c:1663: title: Take A Chance On Me
    (12:47:40) [0x6a2740] [rb_audioscrobbler_print_queue] rb-audioscrobbler.c:1664: length: 243
    (12:47:40) [0x6a2740] [rb_audioscrobbler_print_queue] rb-audioscrobbler.c:1667: timestamp: 2008%2D04%2D27%2019%3A47%3A40
    (12:47:40) [0x6a2740] [rb_audioscrobbler_perform] rb-audioscrobbler.c:828: Submitting to Audioscrobbler: CENSORED
    (12:47:40) [0x6a2740] [rb_audioscrobbler_submit_queue_cb] rb-audioscrobbler.c:1092: Submission response
    (12:47:40) [0x6a2740] [rb_audioscrobbler_parse_response] rb-audioscrobbler.c:701: Parsing response, status=200
    (12:47:40) [0x6a2740] [rb_audioscrobbler_parse_response] rb-audioscrobbler.c:730: RESPONSE: OK
    (12:47:40) [0x6a2740] [rb_audioscrobbler_parse_response] rb-audioscrobbler.c:784: OK
    (12:47:40) [0x6a2740] [rb_audioscrobbler_parse_response] rb-audioscrobbler.c:730: RESPONSE: INTERVAL 1
    (12:47:40) [0x6a2740] [rb_audioscrobbler_parse_response] rb-audioscrobbler.c:787: INTERVAL: 1
    (12:47:40) [0x6a2740] [rb_audioscrobbler_parse_response] rb-audioscrobbler.c:730: RESPONSE:
    (12:47:40) [0x6a2740] [rb_audioscrobbler_submit_queue_cb] rb-audioscrobbler.c:1096: Queue submitted successfully

    • oruen said...
    • User
    • 7 May 2008, 23:09


    I had a similar problem with Rhythmbox and I found another solution. I've installed lastfmsubmitd package from Ubuntu repository - it makes scrobbling right.

    • Imoq said...
    • User
    • 9 May 2008, 18:29
    I just configured lastfm plugin on my rhythmbox today and after putting my lastfm username and password, it scrobbled exactly one song. After that no more songs are being scrobbled.

    I have been lookin in forums for a solution but this thread is the closest I could find. I am using the same opeative system version and Rhythmbox version as the one described here:

    olyons escribió:
    It works for me if I run:

    tail -f /home/[username]/.gnome2/rhythmbox/audioscrobbler.queue when I have Rhythmbox running

    I don't really know why it works but I'm scrobbling now so I'm happy! (I'm running Fedora 8 and Rhythmbox 0.11.3)...

    But the "tail -f" trick doesn't work for me :(. I have disabled and reenabled the plugin and no luck. No new songs get scrobbled. It just says "OK" in status. Of course, I have closed rhythmbox, etc. but can't think about new ideas.


    ¡Sé libre, usa software libre!
    Be free, use free software!
  • Fixed my problem using Fedora 8

    I just downloaded a new version from the "testing" repositories, have been using it for a couple of days, it seems to work flawlessly.

    Check this URL

    Try it out, if you use Fedora 8!

    Good luck!

  • Fedora Core 9 - got it working again

    Hey all,

    I've also had this issue with Fedora for some time now and I really didn't want to get into all the source-compile jazz, so I decided to give it a shot at Fedora's "test" repository.

    As I said, I'm using Fedora 9 and it seems to be working again. Yay!

    Check it at

    Hope that helps someone.

    Thanks to McBrain77 for the tip! ;-)

  • Lenny - Working again


    The recent package in the Lenny repo's seem to be just the right ones.. I updated rhythmbox a few days ago, and now i'm able to submit tracks again :) Woohoo!

    Using Rhythmbox 0.11.5 on Debian Lenny

  • Ubuntu 8.10 - Intrepid Ibex (working)

    Wanna make a heads up. Rhythmbox 0.11.6 on Ubuntu Intrepid, audioscrobbling already working.


    Once GNU is written, everyone will be able to obtain good system, just like air. ~Sir Richard M. Stallman
  • Wanna make a heads up. Rhythmbox 0.11.6 on Ubuntu Intrepid, audioscrobbling already working.

    i have exactly the same disto How can i see if Rhythmbox 0.11.6 really scrobble? Meanwhile the number of pleys in site rest the same. I suspect that Rhythmbox don't scrobble

    ...That's one small step for a man, one giant leap for mankind...;-)
Anonymous users may not post messages. Please log in or create an account to post in the forums.