QTScrobbler linux?

 
  • QTScrobbler linux?

    Hi,

    I've been working with QTScrobbler under Windows XP for a while now (logs created with Rockbox for Sansa Clip+), everything looks good. However, I'm trying to find a way to use the program (GUI) under Ubuntu 10.10 64bit.
    can someone help me out with this?

    Thanks a lot

    • Podex said...
    • User
    • 29 Mar 2011, 10:59
    What is your problem with it exactly? Are you able to compile it?
    You have to get the SVN version because there is no binary version: http://sourceforge.net/scm/?type=svn&group_id=181496

    For me the linux version doesn't work because libmtp that QTScrobbler uses doesn't recognize my player.

    Soulseek/Nicotine: Podex
    Join Real Avatar, for people using pictures of their real faces as their avatar.
  • Sorry for the delay...
    My problem is that I'm not able to compile it. Any chance for a compiling-newbie explanation?

    • Beowulf said...
    • User
    • 17 Jun 2011, 19:37
    You need the development libraries for QT (4.6 or higher), and optionally libmtp. So on debian/ubuntu distros that'd be "sudo apt-get install build-essential libqt4-dev libmtp-dev". Then grab the SVN version from the link Podex gave, cd to the trunk folder, run qmake, then make.

  • Hi,
    I really appreciate the work you're doing and willingness to help. I'm also having a problem compiling. VERY possible I'm not doing it right since I've never compiled anything from an SVN before.

    Immediate problem is when I run the qmake, I get the error:

    RCC: Error in 'qtscrob.qrc': Cannot find file '../language/pl.qm'
    make: *** [build/.rcc/qrc_qtscrob.cpp] Error 1

    When I run make, it also can't find [.../language/de.qm]

    I'm guessing I'm missing a package, but what one?
    I'm running qmake from the Trunk/src/qt directory. Is that correct?

  • P.S. I just tried removing the language references from qtscrob.qrc. Now Make exits with the error:

    /usr/bin/ld: cannot find -lscrobble
    collect2: ld returned 1 exit status
    make: *** [qtscrob] Error 1

    Sorry if these are newb questions, but maybe this will help others too.

    • Beowulf said...
    • User
    • 21 Jun 2011, 19:07
    Run qmake from trunk/src
    That will generate the language files, compile the lib (the -lscrobble error you had), and then compile qtscrob.

  • Thanks so much. It works!

    P.S. and O.T.-- I can only get mp3s to scrobble on my iaudio 9. It won't scrobble flacs or oggs. I'm pretty sure this is a problem with the player and not qtscrobbler. I'm only mentioning this in case other Cowon users see this to corroborate their experiences.

  • Beowulf said:
    You need the development libraries for QT (4.6 or higher), and optionally libmtp. So on debian/ubuntu distros that'd be "sudo apt-get install build-essential libqt4-dev libmtp-dev". Then grab the SVN version from the link Podex gave, cd to the trunk folder, run qmake, then make.

    Thanks! works like a charm.

Anonymous users may not post messages. Please log in or create an account to post in the forums.