Forum » Last.fm Client Support

Linux client and PulseAudio

 
    • [Utilisateur supprimé] a dit :...
    • Utilisateur
    • 17 jan. 2008, 14h29m

    Linux client and PulseAudio

    Hi,

    Can you please post the correct procedure to get Last.fm Linux client working with PulseAudio?

    Kubuntu Gutsy
    Lastfm - 1.3.0.62-2
    PulseAudio - 0.9.6-1
    Alsa 1.0.14-1

    Got PulseAudio working with every app I'm using except this one.
    I can still stream through Amarok but your client has less overhead.

    The changelogs seem to point this as solved by using a default device, but I couldn't find anyone saying he/she got it to work.

    Sorry for the bad english :)


    Bruno

    • wrongside a dit :...
    • Utilisateur
    • 11 fév. 2008, 2h09m
    I just upgraded to client version 1:1.4.1.57486 (the version in last.fm's apt repository), which now works for me with pulseaudio, whereas 1.3 didn't.

    In Tools/Options/Radio, 1.4 gives the option of choosing "Default PCM device" instead of the hardware soundcard. If you've set up your /etc/asound.conf to make pulseaudio your default ALSA device, choosing "Default PCM device" here will make last.fm use pulseaudio.

    • Balachmar a dit :...
    • Utilisateur
    • 9 avr. 2008, 8h25m
    Hi,
    I also want to get this working, but I don't have the above mentioned config file. /etc/asound.conf
    I am running Ubuntu Hardy Heron. And in the sound preferences everything is set to pulseaudio. So where should I make pulseaudio my default alsa device?

  • @Balachmar:

    try: aptitude install libasound2-plugins

    hope that helps :)

    Edit:

    create a file ~/.asoundrc and out this content in it:
    pcm.pulse {
    type pulse
    }
    ctl.pulse {
    type pulse
    }
    pcm.!default {
    type pulse
    }
    ctl.!default {
    type pulse
    }

    • Balachmar a dit :...
    • Utilisateur
    • 20 avr. 2008, 14h37m
    Just to let the rest know, the post above helped :)

    • Loffe87 a dit :...
    • Utilisateur
    • 2 mai 2008, 9h56m
    It worked for me to. Thanks

  • Worked like a charm!!!

    It worked as expected, nice!

  • thanx!

    This worked fine for me!

    Enjoy, Copy, Remix & Share...
  • thx

    this also worked for me!

    I cant see it!
    • [Utilisateur supprimé] a dit :...
    • Utilisateur
    • 5 jui. 2008, 11h44m

    thanks!

    worked for me as well :)

  • ^^

    I thought I was going to have to use pasuspender on it, thanks!

    My ideas about software are regarded as weird.
    • daneeeh a dit :...
    • Utilisateur
    • 27 jui. 2008, 3h39m
    works ok in Hardy Heron, thanks

    • mkaraca a dit :...
    • Utilisateur
    • 8 août 2008, 8h15m

    Works wonders with Ubuntu Hardy!

    Thanks buddy!

    • dieguito84 a dit :...
    • Utilisateur
    • 8 août 2008, 9h04m

    Works very well

    Solved the problem that hang Rhythmbox with the new Last.fm plugin
    Thanks!

  • and then..

    This also worked for me, but I noticed it killed audio in other apps that once worked. I deleted this file and rebooted to get sound working in the other apps, but that disables last.fm's client to work properly.

    • Faz2 a dit :...
    • Abonné
    • 24 sept. 2008, 3h22m

    Flash in Firefox gone silent?

    I had a similar issue and found this great thread via this one at the Ubuntu Forums.

    My problem was that I was unable to play sound from more than one app at once, also having to shutdown Firefox if I'd played Flash (Youtube etc) previously, before it would release exclusive use of sound card. Extremely annoying for us Last.fm addicts. >:^<

    Following the procedure here I gained the ability to play sounds from multiple apps, e.g. Last.fm, VLC. Excellent!! But I now lost Flash audio within Firefox. :(

    As all other audio apps were now working fine, I assumed this had to be due to a Flash config issue, e.g. during it's initial install. So I performd a complete removal of flashplugin-nonfree using Synaptic Package Manager. Performed a reboot for good measure, then re-installed, including libflashsupport, which I don't believe I had before.

    I am happy to report I now have sound everywhere! :)

    Thank you deathrow1986 & bilu!!!

    • travis221 a dit :...
    • Utilisateur
    • 13 déc. 2008, 11h15m

    mplayer only!!

    i had different problem with flash plugin, but the remedium is the same, remove (purge) flashplugin-nonfree, installing instead of this mozilla-mplayer, it works and additionally won't eat all the resources of your CPU for breakfast, good luck :>

    • kasper3000 a dit :...
    • Utilisateur
    • 29 déc. 2008, 18h29m

    Yay, it works!

    Just wanted to add a me too(!!). I followed @deathrow1986's comment and it works nicely now. Thanks @deathrow1986!! =:)

    • [Utilisateur supprimé] a dit :...
    • Utilisateur
    • 13 mars 2009, 14h11m

    Nice!!!!

    Tx! Work!!!! Ubuntu 8.04.2

Les utilisateurs anonymes ne peuvent pas poster de messages. Merci de vous connecter ou de créer un compte pour pouvoir intervenir dans les forums.