scrobbling tracks from mtp devices

  • scrobbling tracks from mtp devices

    I've created a small py-GTK app to scrobble tracks from mtp devices (such as the Creative Zen, or the Zune) to If you use an mtp device, please check it out and let me know how it goes. You can Love/Ban tracks before scrobbling, and also use the ratings from your device if you like 5 stars for love, 1 star for banning.

    github repository
    Launchpad PPA

    Edit: Updated PPA link

    Bearbeitet von woodenbrick am 16. Apr. 2009, 9:12
  • Nooo!

    It doesn't work with Creative Zen V.

  • did you run from the source, or install the deb?
    if you ran the source you may need to install the mtp-tools package manually.
    try running this command from the terminal: mtp-tracks
    if this isn't the problem let me know.

    Edit: it also needs python-elementtree so add that too if necessary.

    • Sojek schrieb...
    • Benutzer
    • 30. Mär. 2009, 22:59
    I plugged in my player but I can't scrobble.

    User authenticated
    Connecting to MTP device Done.
    It is now safe to remove your device.
    Cross checking song data with local database...
    11 tracks checked
    Scrobbling started 0.0 hours ago
    Nothing to scrobble.

    Compiled from source.

    TIA for help.

  • New Release 0.81

    New Release 0.81
    I've released a new version today which includes support for tagging (accessible from the right click menu)
    If you use the PPA, please update to the new one

  • ill try this out with a zune 30, ubuntu 9.04 and tell you how it goes

  • p.s. isnt zune mtpz (coz microsoft are akward?)

  • Connecting to MTP device
    Device not found.

    i thought as much, i can click the wire symbol as much as i want, but that just repeats, looks like cool software though, if it did work

  • Hi Mango, Yes I have since realised that MTPZ is a bit of a bastard, and it's pretty unlikely that this software will work. Do you have access to the zune from ubuntu when it is connected, ie. can you browse the contents?

  • i can find it, if i plug it into, rythymbox after i installed the mtp addon, but it just shows up as zune, thats it, i cant do anything with it, but see its battery in a %. i really hope that helps. coz i wish it worked, coz zenses, does nothing for me. good luck, and ask more questions please!

  • MTPZ requires the zune to authenticate itself with the host computer before files can be sent and received. currently this is only through the official software on windows. Until this is replicated/cracked in some way these devices wont work on linux.

    The only other thing I can suggest is that you connect your device in windows and figure out some way to dump a track listing. I have no clue how or where this data would be stored, or even if it will be accessible. If you manage this, I can then modify MTP-lastfm to work with this data. Since I don't have a zune I cant be more help than that.

  • you can access the device via z suite, i can open it up on my computer now, what would a tracklisting look like? aka file name

  • I have no idea, but if you grab some likely looking files and email them to me I can check them. Also, don't get your hopes up ;)


    • gtianp schrieb...
    • Benutzer
    • 4. Jun. 2009, 18:04

    I've tried that

    It can detect my mtp player but only english songs have been updated.
    Can it support Chinese or Japanese songs, or just English songs?

  • gtian, can you email me ~/.mtp-lastfm/mtp-dump_gtianp so I have some sample data and I'll see if this can be fixed.

  • in the end i got to frustrated with the zune on 3.0, and completely wiped everything and downgraded it to firmware 2.5 now it scrobbles with zenses, phew! but it took me a day gaaaaaaaargh, damn you microsoft!

    thanks for the help though (there werent any files, but artwork and music on it)

    • pouc schrieb...
    • Benutzer
    • 18. Feb. 2010, 10:31
    Hello, it doesn't work with my Archos 104... My MTP player is detected but it always says "nothing to scrobble"... Thanks anyway for your work!

  • It seems probable that the Archos 104 doesn't track playcount, if you want email your mtp-dump file and I can confirm this for you.

  • I really would like to use mtp-lastfm, but unfortunately it is not able to find my MTP-Device (Sony Ericsson K550i [it is a MTP-Device, isn't it?]).
    I tried to unmount with Rhythmbox and Nautilus. But its not working :(
    I also tried to kill the gphoto2-process before connecting, how woodenbrick suggested here:
    I do use Ubuntu 9.10, Karmic Koala.

    • jegHegy schrieb...
    • Benutzer
    • 22. Apr. 2010, 15:41
    PPA version works great with my Sony-Ericsson W995 on Ubuntu 10.04. I've recently reported a crash issue which woodenbrick replied to promptly, and after a few days of cooperation, all is well and the bug is fixed. I encourage anyone with problems to file a bug report for mtp-lastfm on Launchpad. :)

    Thank you once again for this great app!

  • Connection issues

    Anyone who has a device that has trouble connecting to MTP-Lastfm should see this bug report and subscribe if relevant to you.

    Currently I don't know how to solve this, but would be able to let you know in the future if it's fixed.

    • magicw schrieb...
    • Benutzer
    • 2. Mai. 2010, 15:39
    mtp-lastfm works great with my ZenMozaic since 10.04 is installed. It did not work on 9.10.

  • Rhythmbox scrobbles my iPod Nano 4G tracks out-of-box, without installing ANY additional software.

    • bigd2k6 schrieb...
    • Benutzer
    • 13. Mär. 2012, 19:10
    This topic is probably dead by now, but I'm asking for help anyways. I used to use mtp2lastfm to scrobble, but I've been getting errors with that lately, so I went on the prowl for a new MTP scrobbler and I found your mtp-lastm scrobbler.

    Now it worked wonderfully well the first time around, but now, when I load up mtp-lastfm it brings me to the login screen and that's it, it's gone after that.

    I have a creative zen visiom M and was able to scrobble once, now I can even get the program to load.

    Oh and I got the program from the Ubuntu Software center.

    I even restarted my PC, removed and re-installed the program, and it still does the same thing.

    Check out
Anonyme Benutzer dürfen keine Beiträge schreiben. Bitte log dich ein oder registriere dich, um Beiträge in den Foren schreiben zu können.