yet another mtp scrobbler

 
  • Brilliant

    I was using the universal scrobbler (http://lastfmstats.livefrombmore.com/universalscrobbler/), but this is a lot more convenient. Sony c905, just worked with no fiddling. Excellent.

    @bezgubov - I saw the same errors the first time I used this app, and I think the problem was that amarok had grabbed my mtp device. Quitting amarok allowed mtp-lastfm to do its work.

  • Ubuntu 9.10

    By the way, how to make it work in Ubuntu Karmic? Here is the code from terminal:
    mtp-lastfm
    Connection Time allowance: 15 seconds
    usb_claim_interface(): Device or resource busy
    LIBMTP PANIC: Unable to initialize device
    mtp-tracks: There has been an error connecting. Exit

    Thanks

  • Karmic automounts mtp devices on connection. I think the easiest way (for now) is to open rhythmbox/amarok and mount/unmount your device there. After that it should work properly. I still haven't had a chance to fix this since I don't use Karmic.

  • Ubuntu 9.10

    Thank you for your answer, but MTP-Lastfm can't connect with my player even after unmounting the device in rhytmbox, amarok, nautilus or on the gnome-panel.

    Does anyone successfully use the program on Karmic?

  • My wife has Karmic installed and I can run the software successfully, it was a bit fiddly to get working though, can't remember exactly what I did...
    You could try ps -A | grep 'gphoto' in a terminal and then kill the gvfs-gphoto2-vo process before connecting.

  • It does'nt with my iriver e50. :(

    Слава Люциферу!
  • I really would like to use mtp-lastfm, but unfortunately it is not able to find my MTP-Device (Sony Ericsson K550i [it is a MTP-Device, isn't it?]).
    I tried to unmount with Rhythmbox and Nautilus. But its not working :(
    I also tried to kill the gphoto2-process before connecting, how woodenbrick suggested.
    I do use Ubuntu 9.10, Karmic Koala.

  • Connection issues

    Anyone who has a device that has trouble connecting to MTP-Lastfm should see this bug report and subscribe if relevant to you.

    Currently I don't know how to solve this, but would be able to let you know in the future if it's fixed.

    • bigd2k6 schrieb...
    • Benutzer
    • 6. Mai. 2010, 20:40
    Hey, will this program work with Ubuntu 10.04 Lucid Lynx? I've been using mtp2lastfm for Ubuntu 8.04, but it doesn't seem to work for 10.04.

    Check out Leaptrade.com
    • bigd2k6 schrieb...
    • Benutzer
    • 6. Mai. 2010, 21:39
    I think I figured my problem out. Once I connect my zen to my computer, I went to computer right clicked on the Zen and unmounted it. It seemed to work.

    Check out Leaptrade.com
  • any news?

    unfortunately, I still have trouble with connecting my meizu m6 sl (firmware 2.004.7) and my computer (os - gnu/linux ubuntu lucid)

    when I open the app in terminal it says that the device is busy :(

    ignoring usb_claim_interface = -16ignoring usb_claim_interface = -22PTP_ERROR_IO: Trying again after re-initializing USB interface
    . . .
    ignoring usb_claim_interface = -16ignoring usb_claim_interface = -22LIBMTP PANIC: Could not open session! (Return code 767)
    Try to reset the device.
    Error connecting

  • How about iRiver E50?
    $ mtp-lastfm
    No Device attached


    Can you help in this problem?
    I think problem in mtplibs:
    $ mtp-connect
    libmtp version: 1.0.3

    No devices.

    • Quezak schrieb...
    • Benutzer
    • 22. Nov. 2010, 17:38

    SE

    I've got a question: how is it supposed to work on Sony Ericsson phones? Nothing really happens and I don't know what *should* happen :P When connecting the phone should I choose File Transfer mode or Phone Mode? Or maybe the W200i is too old to work with this software?

    • joei666 schrieb...
    • Benutzer
    • 4. Aug. 2011, 18:10
    Amazing! Added the repository, installed, started program, logged into last.fm and connected my w910i in media transfer mode.

    worked like charm! very good work! thank you!

    • derMOGE schrieb...
    • Benutzer
    • 7. Dez. 2011, 9:53
    I've got some trouble with the prog. I'm using ubuntu 11.10 and installed it from your ppa...

    if I start now the prog at the console I get this:
    (mtp-lastfm:4329): Gtk-WARNING **: Im Modulpfad »pixmap« konnte keine Themen-Engine gefunden werden, (mtp-lastfm:4329): libglade-WARNING **: could not find glade file '/usr/local/bin/glade/gui.glade' Traceback (most recent call last): File "/usr/local/bin/mtp-lastfm", line 54, in <module> test_mode=options.test_mode) File "/usr/local/lib/python2.7/dist-packages/mtplastfm/main.py", line 69, in __init__ self.tree = gtk.glade.XML(self.GLADE['gui']) RuntimeError: could not create GladeXML object

    Any idea what to do?

Anonyme Benutzer dürfen keine Beiträge schreiben. Bitte log dich ein oder registriere dich, um Beiträge in den Foren schreiben zu können.